Dynadot

Is there a problem with GoDaddy appraisals not working?

NameSilo
Watch
Impact
55
For me, Godaddy Appraisals just gives a blank screen when I try to use it. Is it not working for anyone else or is it just me?
 
1
•••
The views expressed on this page by users and staff are their own, not those of NamePros.
0
•••
0
•••
For about two weeks it has stopped working on Safari but still works on Chrome on the same Mac or iOS machine. At least that is situation for me (M1 Mac, older iPad). It is a pain as I generally use Safari as the default browser on the iPad.

@James Iles
 
0
•••
For about two weeks it has stopped working on Safari but still works on Chrome on the same Mac or iOS machine. At least that is situation for me (M1 Mac, older iPad). It is a pain as I generally use Safari as the default browser on the iPad.

@James Iles
That's weird. I use Chrome and it stopped working for me...
 
1
•••
There is another thread about this and it appears that Chrome (on PC) is the main browser affected by whatever bizarre change GoDaddy made to their valuation page.

I can use Firefox and Safari on my iPhone all day long, but Chrome craps out 100% of the time.

@James Iles
 
Last edited:
1
•••
1
•••
This is indeed totally weird, as it seems to work on different browsers for different people. I checked again to make sure that my my recollection was not wrong, but indeed on my M1 Mac it works fine with Chrome, but the blank page thing with Safari, but some other people seem to have the reverse.

I have no idea what could be causing this.

For those with Domain Academy access (through Discount Club at GD), you can put in a list of up to 150 per day and get the results, more than just a single figure, in spreadsheet friendly format all in one go.

-Bob
 
0
•••
Thanks for sharing your experiences. As with most products, GoDaddy has limitations on usage that may be hit if that usage is high in a short period of time. We will investigate to see if this is the case here or not.

@Bob Hawkes, we'll reach out to you to see if you can give us more information on your experience as an example.
 
0
•••
Now it seems to be working on Chrome but none of the others for me.. Weird.
 
0
•••
In case you did too many appraisals, two things can happen (my friend told me :xf.wink:)
1. You get the message "too many requests." - Solution: Turn on the VPN and do it again
2. It simply nothing happening; it shows other domains related to yours, but not the one you asked for; then you have two ways:

a) Go into Inkognito Mode of your browser; most likely it will work
b) Turn on VPN + go in Incognito

I have no experience with that; I just heard that :troll:
 
1
•••
By the way. My Friend told me that even if he did no appraisal for a long time, it's not working in Chrome - only with incognito.
So, I guess there is a Cookie not fetching correctly.
 
0
•••
After I invoked developer mode in Safari, it magically started working for me, and stayed working even when I then turned Safari developer menu off again.

So at moment it is working for me both Chrome and Safari on M1 Mac (but not on iOS).

-Bob
 
0
•••
This is indeed totally weird, as it seems to work on different browsers for different people. I checked again to make sure that my my recollection was not wrong, but indeed on my M1 Mac it works fine with Chrome, but the blank page thing with Safari, but some other people seem to have the reverse.

Mine were Chrome on PC (problems) and Safari on iOS (worked), so at least we're not exact.
 
Last edited:
0
•••
Back